Experimental music, photography, and adventures

Archive for the 'Geek' Category

Some more geek stuff

Friday, April 4th, 2008

My computer parts arrived yesterday. I wasn’t home when UPS tried to deliver them, but I called them and they let me go to their warehouse to pick up the parts, even though their operating hours technically end at 6. That was pretty nice of them, I’m pretty happy with UPS right now.

Anyway, I’m building a mostly-new system, since my old one kicked the bucket. For those interested, I got an AMD Athlon 64 X2 6400+, ASUS motherboard, 2 gigs of RAM (for now), 500-gig hard drive, case, etc. Unfortunately all I’ve gotten to do with it so far, after putting everything together, is install Windows. That seemed to go without a hitch until I realized that my system drive is somehow the I: drive. I am assuming that this is because I also installed my old hard drives, which may have retained their old drive letters somehow.

Does anyone know if there’s an inherent problem having Windows XP on a drive other than C:? I haven’t noticed any problems yet, but I’m really not sure if this is a good situation.

Once I get Windows up and running, I’ll be installing Kubuntu, probably the x64 version. Windows has been my primary operating system for a while now, mostly because of work, but I’d really like to get back to making Linux my primary OS. I think that, even for working from home, it should be mostly doable, with a VPN client and some sort of VNC software running at both home and work.

More computer woes

Friday, March 28th, 2008

At Noah‘s suggestion, I ran some tests on my power supply last night. I tried what I’ve dubbed the “paperclip test,” which he described to me as follows:

Take the old power supply, unhook it completely from your computer
(including the 4-pin plug if it has one) and then plug it into the wall.  Hook up a jumper (bent paper clip) between the green wire (there should be only one on the main plug) and any of the black wires.  The power supply fan should fire up.  If it does not, the PS is toast.

The fan did spin up, much to my surprise. Noah also suggested testing the voltage in the wires, but I couldn’t find my multimeter (terrible, I know, I’m turning in my geek card today). Still, it’s a good technique so I’m posting it here.

If it does fire up, use a multi-tester (I know you have one,  you of all people I know must have one) and check the voltage from any of the black wires to all the colored ones.

From ground to any of the yellow wires, you should get about +12VDC.
Ground to red: +5VDC.
White: -5VDC.
Orange: +3.3VDC.

IIRC, ground to purple should be +5VDC even when the green-to-black jumper is unplugged.

I double-checked the voltages on Wikipedia and they’re correct.

I had an extra power supply on hand, but it failed the paperclip test, so I knew it was dead. I bought a new power supply, hoping that would fix it. It didn’t. I disconnected everything from the outside of my computer, took out all the expansion cards, and disconnected all unnecessary cables inside. I tried reseating my RAM, and tried each DIMM independently. Still no go. I figure my motherboard and/or CPU must be shot. Great!

So, I started using my older computer, which I’ve dubbed “Maddog.” Maddog is an older computer I built that runs FreeBSD. It used to be a server appliance prototype, in a small form factor, but over the years most or all of the components have been replaced. But it’ll always be Maddog to me. I digress …

Maddog worked pretty well last night, as always. Maddog has always been rock solid — not fast, but uber-reliable. However, this morning I went to check my e-mail, and I saw that Maddog had rebooted overnight. I logged in and started X.org. After about 20-30 seconds, Maddog spontaneously rebooted. Later, I tried logging in again and the same thing happened.

So now, both of my computers are unusable. I need to act fast, as I have a lot of work I need to do and data I need to get to. Fortunately there’s nothing I need for my job on there, so in that sense I’m OK, but … this aggression will not stand!

I’m starting to suspect a power surge or two may be responsible for these problems, especially since we have had some storms in the past couple of days, but I have both systems plugged into different outlets/surge protectors. And Sarah’s computer is in the same room and appears to be fine, so I’m not sure I’m sold on that explanation. Unfortunately I won’t be able to do any troubleshooting until Sunday at the soonest, as we’ll be in Fort Wayne most of the weekend.

One of those mornings …

Thursday, March 27th, 2008

It’s been one of those mornings. You know the ones. Seemingly everything goes wrong, including small and fundamentally unimportant things, but eventually they build to one giant heap of frustration.

I woke up late and stumbled into the second bedroom that functions as our home office. My computer was turned off and I couldn’t seem to turn it back on. I unplugged the power cord, and suddenly the computer sputtered, lights flashing and fans spinning, for about half a second, then fell silent again. It did this a few more times — with no power source connected! I was more than a little creeped out by this, and frustrated that it wouldn’t work. I messed with it for a few minutes, but ultimately gave up. I hope I’ll be able to fix it later. I used my file server to send an e-mail to work saying I’d be a bit late.

I got ready to ride to work and looked outside. Rain, as predicted. Great. When I went to extract my coffee mug from the dishwasher, I hit it on the underside of the counter where the dishwasher is screwed in, covering the mug with sawdust. I dropped the lid on the floor and it got covered in gunk. This was not going well. I almost forgot about three different items and kept having to go back for them as I continued my struggle toward the door.

Once I exited my apartment, I realized it was wet and foggy, but not actually raining much. Actually it was quite pleasant outside, a nice quiet morning. I paused to admire some buds on the trees in front of my apartment.


Budding trees

As I started riding, I felt better almost immediately. I actually like riding on cool, overcast, foggy days, if I don’t get too wet. There were very few people in sight until I reached campus, which had quite a bit of foot traffic. Some fields and paths off 7th Street approaching Jordan were flooded.


Path


Flowers have been planted on campus

When I got past campus I once again had the roads to myself. I didn’t push myself and savored the ride, knowing soon I’d be mired in work. I wished I could have ridden off into the distance.


Green light, and fog

I did take a slight detour to capture this:


Johnson’s Creamery

Even though it’s no longer a creamery, this is a real Bloomington landmark. All in all, a great ride to work. The ride home promises to be much, much wetter.

Ear to the Breeze is proudly powered by WordPress
Entries (RSS) and Comments (RSS).